Skip to main content
← All vulnerabilities
CVE-2026-8203GHSA-9V2G-37MP-QPXF

Concrete CMS 9.5.0 and below has Stored XSS on the height parameter

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Concrete CMS 9.5.0 and below has Stored XSS on the height parameter. The controller does not validate or sanitize $height. Any user with editor privileges can inject malicious JavaScript that executes in the context of any visitor's browser, potentially leading to session hijacking, credential theft, or other malicious actions. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.3 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks Alfin Joseph for reporting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Concrete CMS Concrete CMS

    From 5 · through 9.5.0

  • concrete5/concrete5Packagist

    fixed in 9.5.1

References 1

documentation.concretecms.org