Skip to main content
← All vulnerabilities
CVE-2026-8197GHSA-H72C-XX3W-W8H7

Concrete CMS 9.5.0 and below is vulnerable to Stored XSS via OAuth integration name

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Concrete CMS 9.5.0 and below is vulnerable to Stored XSS via OAuth integration name. The OAuth authorize template renders the integration name (admin-controlled) through Concrete's t() translation helper as a sprintf-style format. The <strong>...</strong> wrap is built by PHP string interpolation before t() runs, so the integration name lands in the translated output as raw HTML. A rogue admin could potentially snoop on login submissions.The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.3 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N  Thanks Yonatan Drori (Tenzai) for reporting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Concrete CMS Concrete CMS

    From 5.0 · through 9.5.0

  • concrete5/concrete5Packagist

    fixed in 9.5.1

References 1

documentation.concretecms.org