WebDyne versions from 3.007 before 3.022 for Perl execute .psp files outside the document root via path traversal in the PSGI API route…
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.022
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
WebDyne, a Perl framework for serving .psp template pages, is affected through its PSGI handler, which allows remote attackers to run embedded Perl code from .psp files located outside the intended document root. The impact is arbitrary code execution on the server, which could expose or alter any .psp file the server can read.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
WebDyne versions from 3.007 before 3.022 for Perl execute .psp files outside the document root via path traversal in the PSGI API route fallback. When a request matches no file, the PSGI handler retries it as an API route through api_filename. That keeps .. segments in the request path and only checks that the joined path starts with the document root, which a request for /../private passes. A remote attacker can run the embedded Perl in any .psp file the server can read, such as one uploaded to a directory outside the document root.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- WebDyne
From 3.007 · fixed in 3.022