CVE-2026-77635GHSA-FXF7-VHH8-7VPQ
CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.1.10, 5.2.15, 5.3.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- cakephp cakephp
From 5.1.0 · fixed in 5.1.10; From 5.2.0 · fixed in 5.2.15; From 5.3.0 · fixed in 5.3.7
- cakephp cakephp/database
From 5.1.0 · fixed in 5.1.10; From 5.2.0 · fixed in 5.2.15; From 5.3.0 · fixed in 5.3.7
- cakephp/cakephpPackagist
From 5.3.0 · fixed in 5.3.7
- cakephp/cakephpPackagist
From 5.2.0 · fixed in 5.2.15
- cakephp/cakephpPackagist
From 5.1.0 · fixed in 5.1.10
- cakephp/databasePackagist
From 5.3.0 · fixed in 5.3.7
- cakephp/databasePackagist
From 5.2.0 · fixed in 5.2.15
- cakephp/databasePackagist
From 5.1.0 · fixed in 5.1.10