Skip to main content
← All vulnerabilities
CVE-2026-77405GHSA-33MJ-CW25-M34HGO-2026-6492

RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.13.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • rabbitmq amqp091-go

    fixed in 1.13.0

  • github.com/rabbitmq/amqp091-goGo

    fixed in 1.13.0

References 4

GitHub · rabbitmq/amqp091-go