Skip to main content
← All vulnerabilities
CVE-2026-77181

Apache Syncope: ClientApp update entitlement not effective

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Incorrect Authorization vulnerability in Apache Syncope. An administrator with ClientApp's update entitlement is unable to perform the related operation, while ClientApp's create entitlement is checked both for create and update operations on ClientApp. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.syncope.core.am:syncope-core-am-logic

    From 3.0.0-M0 · through 3.0.16; From 4.0.0-M0 · through 4.0.7; From 4.1.0-M0 · through 4.1.2

References 1

lists.apache.org