CVE-2026-75915GHSA-H539-C7R8-3XQ4
CodeWhale before 0.8.64 Environment Variable Leak via js_execution
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.8.41, 0.8.64
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: poc
- Automatable: yes
- Technical impact: partial
Summary
CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Hmbown CodeWhale
From 0.8.32 · fixed in 0.8.41
- Hmbown CodeWhale
From 0.8.32 · fixed in 0.8.41
- Hmbown CodeWhale
From 0.8.41 · fixed in 0.8.64
- Hmbown CodeWhale
From 0.8.41 · fixed in 0.8.64
- deepseek-tuicrates.io
From 0.8.32 · through 0.8.41
- deepseek-tuinpm
From 0.8.32 · fixed in 0.8.41
- codewhale-tuicrates.io
From 0.8.41 · fixed in 0.8.64
- codewhalenpm
From 0.8.41 · fixed in 0.8.64