Skip to main content
← All vulnerabilities
CVE-2026-75912GHSA-C6MW-8XH8-GPQ6

CodeWhale before 0.8.64 Argument Injection via git_blame

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.8.41, 0.8.64
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

CodeWhale versions before 0.8.64 contain an argument injection vulnerability in the git_blame tool that allows attackers to read arbitrary files by injecting git options into the unvalidated rev parameter. Attackers can supply rev values like --contents=/path/to/file to exfiltrate sensitive files such as SSH keys and credentials through the tool output returned to the model.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Hmbown CodeWhale

    From 0.3.27 · fixed in 0.8.41

  • Hmbown CodeWhale

    From 0.3.27 · fixed in 0.8.41

  • Hmbown CodeWhale

    From 0.8.41 · fixed in 0.8.64

  • Hmbown CodeWhale

    From 0.8.41 · fixed in 0.8.64

  • deepseek-tuicrates.io

    From 0.3.27 · through 0.8.41

  • deepseek-tuinpm

    From 0.3.27 · fixed in 0.8.41

  • codewhale-tuicrates.io

    From 0.8.41 · fixed in 0.8.64

  • codewhalenpm

    From 0.8.41 · fixed in 0.8.64

References 3

GitHub · Hmbown/CodeWhale

vulncheck.com