Skip to main content
← All vulnerabilities
CVE-2026-75911GHSA-GX45-XRJ5-G6C4

CodeWhale before 0.8.64 Remote Code Execution via allow_shell

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.8.41, 0.8.64
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Hmbown CodeWhale

    From 0.8.6 · fixed in 0.8.41

  • Hmbown CodeWhale

    From 0.8.6 · fixed in 0.8.41

  • Hmbown CodeWhale

    From 0.8.41 · fixed in 0.8.64

  • Hmbown CodeWhale

    From 0.8.41 · fixed in 0.8.64

  • deepseek-tuicrates.io

    From 0.8.6 · through 0.8.41

  • deepseek-tuinpm

    From 0.8.6 · fixed in 0.8.41

  • codewhale-tuicrates.io

    From 0.8.41 · fixed in 0.8.64

  • codewhalenpm

    From 0.8.41 · fixed in 0.8.64

References 3

GitHub · Hmbown/CodeWhale

vulncheck.com